Helpful Docs to read before posting: (All Docs) | Config Docs | General FAQ | Mailing List Sending FAQ | Error FAQ

FCKEditor - Problem with image inside message body

Have a question about any of the Dada Mail plugins/extensions?

FCKEditor - Problem with image inside message body

Postby rodrigomartinho » Fri Mar 30, 2012 9:12 am

Hello.

I am using FCKEditor in Dada Mail. I wrote an email with an image in the message body, not as an attachment (I copied the image and pasted it into the message body). I sent the email to my mailing list and people with a gmail or hotmail account reported that they couldn't see the email, only a large bunch of characteres.

I checked with my gmail account. In Thunderbird, I can see the email properly. In gmail's webmail, I see only the bunch of characteres.

This was reported by many gmail and hotmail users, so it leads me to think this is a problem with webmails in general.

Any clue about why this is happening, and how to prevent it?

Thanks in advance,

Rodrigo Martinho.
rodrigomartinho
 
Posts: 7
Joined: Fri Mar 30, 2012 9:02 am

Re: FCKEditor - Problem with image inside message body

Postby rodrigomartinho » Mon Apr 16, 2012 11:37 am

Anyone?
rodrigomartinho
 
Posts: 7
Joined: Fri Mar 30, 2012 9:02 am

Re: FCKEditor - Problem with image inside message body

Postby justin » Mon Apr 16, 2012 4:18 pm

Send a sample to my test email address:

dadamailtest@gmail.com

And I'll see if it's happening to me,
User avatar
justin
 
Posts: 5130
Joined: Wed Feb 13, 2008 8:41 pm
Location: Denver, CO

Re: FCKEditor - Problem with image inside message body

Postby rodrigomartinho » Tue Apr 17, 2012 8:18 pm

Hello Justin.

I have forwarded the original e-mail with the problem to you.

Thanks for your help.

Regards,

Rodrigo Martinho.
rodrigomartinho
 
Posts: 7
Joined: Fri Mar 30, 2012 9:02 am

Re: FCKEditor - Problem with image inside message body

Postby rodrigomartinho » Wed Apr 25, 2012 5:16 am

Hello Justin, were you able to take a look at this issue?
rodrigomartinho
 
Posts: 7
Joined: Fri Mar 30, 2012 9:02 am

Re: FCKEditor - Problem with image inside message body

Postby justin » Wed Apr 25, 2012 9:13 pm

I have forwarded the original e-mail with the problem to you.



Instead of forwarded me the message, can you subscribe that address to your list, so I can see exactly how it's being sent out?
User avatar
justin
 
Posts: 5130
Joined: Wed Feb 13, 2008 8:41 pm
Location: Denver, CO

Re: FCKEditor - Problem with image inside message body

Postby rodrigomartinho » Fri Apr 27, 2012 10:32 pm

Hello Justin.

I created a test mailing list and sent a test e-mail for you and me (both gmail acounts).

For my account, the problem was exactly the same. I could see the e-mail properly in thunderbird, but not in gmail's webmail.
rodrigomartinho
 
Posts: 7
Joined: Fri Mar 30, 2012 9:02 am

Re: FCKEditor - Problem with image inside message body

Postby justin » Sun Apr 29, 2012 7:36 pm

Maybe this is what's confusing me:
I wrote an email with an image in the message body, not as an attachment (I copied the image and pasted it into the message body)


I'm not sure if I've ever "copy and pasted an image into the message body." I think you may need to get the image uploader to work with FCKeditor and add an image, like that.
User avatar
justin
 
Posts: 5130
Joined: Wed Feb 13, 2008 8:41 pm
Location: Denver, CO

Re: FCKEditor - Problem with image inside message body

Postby justin » Sun Apr 29, 2012 7:50 pm

Huh, I'll be darned, I guess you can just copy/paste an image, although it's not something Dada Mail is aware of, so it doesn't do a good (read: any) job at interpreting it.

What should probably happen, is that Dada Mail would notice the embedded image in the source of the message, save it and attach it, similar to how you would have any other image upload. I'll add an issue about this,
User avatar
justin
 
Posts: 5130
Joined: Wed Feb 13, 2008 8:41 pm
Location: Denver, CO

Re: FCKEditor - Problem with image inside message body

Postby rodrigomartinho » Sun Apr 29, 2012 11:39 pm

Hello Justin.

I sent another test email, now using the insert image button, and it worked for me both in thunderbird and gmail's webmail.

So, seems this is the right way of embedding an image into email body, but for this to work one must upload the image to server and keep it there. If the image is deleted, the email doesn't show it anymore, as expected. The copy and paste method is easier and the image goes within the email, so it would be good if it worked this way too. But it isn't a major issue.

I had to upload the image by ftp, I'll try to make the connector working.

Thanks for your help.
rodrigomartinho
 
Posts: 7
Joined: Fri Mar 30, 2012 9:02 am

Next

Return to Questions

Who is online

Users browsing this forum: No registered users and 0 guests

cron
Loading